HyperKat Support and Tester Forum

Mars Challenger V1.0 => Mars Colony:Challenger => Topic started by: Hyper on June 01, 2013, 05:11:40 PM

Post by: Hyper on June 01, 2013, 05:11:40 PM
Bugs.... other subjects, opinions and general chat use a different topic...
Post by: rditto48801 on June 10, 2013, 02:47:44 AM
I got around to playing some MC:C tonight.

bug or feature?
When cleaning the Seperator, the waste level of the Valves seems to occasionally spike to a negative value.
Two times I seemed to end up with a little more waste in the waste container than there should be.
One example (from the last time I cleaned the Seperator) 0.52 (Valve) + 1.1 (Filter) = 1.7 (in waste container). That's basically a 'free' 0.08 unit of chemical waste.

bug or feature?
The external lights are on during the day.

Sounds are still fairly low in game.
I keep hearing the occasional 'crackle' or 'pop', almost like a brief split second bit of static or something.
The console shows no mention of 'random sounds' when these occur, so I am guessing it is just a side effect of having my volume turned up a good bit due to in game volume being so low.
Post by: rditto48801 on June 14, 2013, 05:57:21 AM
Another brief bug report.
I previously reported an issue where I would get a pressure/O2/CO2 mix warning, take 9 damage and then get a message that pressure/O2/CO2 was normal again.
I had it happen again, and I think I am might have a probably cause.
The doorways. I was heading past the plant processor, entering the 'corridor' heading to the bio lab hub when it hit. At least one other time I also recall 'leaving' the central part of the farm hub when it occurred.

One previous issue I mentioned (in 1.05) that radiation levels 'changed' when going through an inner airlock doorway. 

Is it possible the same basic thing is at fault for the air mixture issue is at fault?
That there is some sliver of a spot in the doorways that, if hit at the right time, causes the game to 'think' the player is actually outside without protection for a single 'tick' of the game checking the player's 'immediate surroundings/environment'?
Post by: Hyper on June 15, 2013, 08:58:52 AM
Yes the doorways have been an issue but I added a secondary check and that issue should be fixed. We had lots of problems in beta with that sort of thing. I will look at doing it a different way. It still does it in random places/times so it is something I will address.

Post by: rditto48801 on June 18, 2013, 03:58:20 PM
A bug I stumbled upon by accident.
Accidentally clicking on a door switch for an open door twice will result in the door remaining open, yet the switch will still read green/safe. Doing it multiple times has the door remain green/safe so long as the door is not fully closed.

This does not appear to affect a door starting in the closed position, the button goes red/open the moment the button is pressed and the door starts to open, yet switches to green/safe if the button is pressed a second time to close the door again.

If the door is closed, and then opened with a press of the button, then the button pushed to close it before it is fully opened, and quickly pressing the button a third time to open it before it closes all the way, the door will remain open with the button reading green/safe.

I have not dared to test to see if this will allow for both doors in an airlock to open at the same time, or if the bug is just with what the door button shows.

Edit: One other observation. I got a deposit tested at Nickle 3.000, but after two full ore boxes, it seems to have only increased Nickle supply by about 2 units total (at 2.8, had 0.6 before iirc).
Is this a bug or bad luck with the rng? I will take note of if the next two change it much (both of my augers are on an Olvine deposit right now) (edit 4: first load brought it up to 4.0, so just 1.2)(edit 5: second load brought it up to 5.2, so roughly 1.2 per load).

Edit 2:
On the subject of augers, one thing I forgot about until now.
Bug or feature? Having an auger on a speed greater than 1 will do damage it when retracting the drill to depth 0. (Remembered it when noticing the auger that has some extra drill wear on it when preparing it to be relocated)

Edit 3:
Bug or feature? When setting the Auger for 0.00 depth , when it reaches 0 depth, it stays on and the drill keeps turning. (noticed when preparing to mount it on a rover and relocate it)

Edit 5:
Bug or feature? Mineral resources are not added to storage until after the ore processor has finished the entire load of ore it was processing.

Edit 6: Tweaked post format a little

Edit 7:
Two more bugs/issues I strayed across after some mining.
First, when removing Potassium from storage, it went from 1.8 to 0.79999, probably more if the list was able to handle longer numbers.

The second issue... which made me sad.
Above Potassium was the last thing I needed to finally make some NPK Fertilizer.
After making two, I got curious as the items had the same icons as the other repair kits.
A right click shows it has a 'blank' entry, and the cancel option.
The game does not recognize them as fertilizer. I tried a few places (planter, algae nutrient recipe, fertilizer storage), and nothing. Kind of disappointing after spending a while to move a total of 16 units each of the needed elements into the base. (first in biolab, then in fabrication after remembering it was made in the fabrication desk not the chemistry desk... so 24 trips total...).
So I know have a pair of 'useless' NPK Fertilizer taking up a slot in one of the fabrication storage cabinets...

An update of  an earlier bug/issue, of rover lights not illuminating the ground when going down hill. I have to go over a hill to get to my latest mining location, and noticed items like the augers are still illuminated properly by the rover lights, even though the ground remains dark.

Edit 8:
After doing a little work and exiting (to 'save and quit and reload'), one of the last thing I did was make another batch of NPK fertilizer, for the heck of it. After quitting to the main menu, and re-entering the mission, the P and K was back in my inventory. When I went to exit out again to save and get a copy of the log, the game crashed while exiting the mission. I made a copy of the console log.
Post by: kyleus on June 22, 2013, 09:20:23 PM
1.  Was out to pick up a rock and forgot that I had the PLIBS in my hand.  The PLIBS was replaced by the rock and I searched around for the PLIBS.  It reappeared after relogging back in its original spot in the hab.

2.  Had several instances where Oxygen and Carbon Doixide Warnings go off and immediately get the pressure/mix normal "all clear" but results in about 10 damage each time it happens.  Taking Propadine and "rest" restores total health.

3.  Still suspicious about "needing" to go to the toilet immediately after eating and/or drinking.  I did not try to see if the bio waste adds up.

4. In phase 3, I got a notice that I opened a pressurized door (to the ELS) when the module pressure was normal.  It would also say that I opened a pressurized door when closing the same door.

4.  In Phase 3, I had my helmet off and had logged out when I logged back in, I could not toggle helmet in the ELS.  I "found" my helmet in the EVA locker but I had NOT taken it off there.  I was using the ELS for helmet doff/don.

5.  In Phase 3, I found and used the waste cans for the water filter/pump and the waste cans would magically reappear in original positions and were empty between log-ins.
Post by: rditto48801 on June 23, 2013, 11:26:32 AM
@ kyleus
I have already reported 1, 2 and 5.
It is nice to know I am not the only to have had problems with 1 and 5. I ran into those back in 1.04. It is nice to know the PLIBS 'reset' for you. I didn't take any chances when the 'vanishing PLIBS' thing happened to me,  I slightly panicked and forced closed MC:C without saving via task manager when it happened to me.
5 becomes less of an issue once in Phase 4+.

Hyper is already aware of 2, just check his last post in this thread. It seems to be connected to the doorways in the base.
Where do you experience this issue at? I seem to run into it most when exiting or leaving the central hub of the farm.

For 3, are you saying you get a message you have to go after 'every' food or drink item consumed?
For me, I think 3-4 food/drink items need to be consumed before it gives a message saying I 'have' to go.
It is apparently 0.5  gallons of bio waste for every drink or food item consumed.
I guess it is for simplicity, but it does mean sticking to a diet of algae based foods or single plant or meat item meals for minimal food bar increase helps to build up bio waste quickly.  Very handy for building up extra materials for organic fertilizer.
There is an issue where organic fertilizer is not usable for making algae nutrients in Phase 5+, so it helps to rely mainly on organic fertilizer for plants once getting to Phase 4, or plan to have fertilizer based algae as one of the first algae types grown once Phase 5 rolls around since algae based fertilizer should create proper NPK Fertilizer itself.
Post by: Hyper on June 23, 2013, 05:59:02 PM
These issues will be addressed for 1.07 thanks.
Since you know they exist avoid the issues and carry on..
Post by: rditto48801 on June 23, 2013, 07:06:52 PM
I think I broke the score system.
Started Phase 7 (after 40 hours in Phase 6), moments after Phase 7 started, I got a message saying all work orders were completed. I checked, and work orders were basically for everything I had done previous in Phase 6... I figured I would just end the mission, and Phase 7 was 100%, and my total average was about 74%... but my records say my final score is 133.799 (which I think is kind of amusing, in terms of 'leet speak', or however it is called)
Post by: Hyper on June 27, 2013, 09:21:35 AM
The next time anyone gets a oxygen/co2 warning please stop, log out of the game and send me the console.log file. I am trying to find the exact point this happens for the 1.07 patch.... thanks..
Post by: kyleus on June 27, 2013, 10:15:12 PM
1.  Got the O2 damage twice in the same round.  Sorry, didn't see your note until later.  Will get the log soon.  I happens often to me - usually just puttering in the garden hab or around the worm/algae tanks.  Doesn't seem to be just after opening or crossing a doorway.

2.  Made some plastic in Phase 5.  Put the 2 units in the locker.  After relog, the units were gone.  Did it again with another 2 packets to confirm - disappeared from inventory again.  POOF!  Did a quick search around the hab but saw no one.  No odd foot/tire prints outside either. ;-)

3.  Just an observation - NOT A PROBLEM: the bowl and glass at the sink in the kitchen have some alpha-layer occlusion going on for me and they appear like 1/2 containers.  I'll try to get a picture in-game.
Post by: Hyper on June 28, 2013, 12:07:40 PM
Item storage was a bug, fixed
refer to subject "patch 1.07" for updates will release it soon as we get the oxygen problem fixed.
I hardly ever have the oxygen issue so it is hard to trap the event. Logs will help

Post by: rditto48801 on June 28, 2013, 05:34:25 PM
Is there anything from my game data that would be useful for looking into the broken score issue I had? Or can I safely start a new game without hindering whatever efforts are needed to look into the broken score issue?
Post by: Hyper on June 28, 2013, 06:40:41 PM
Go ahead and play the game. Keep track of how you foil the system and let me know
Post by: rditto48801 on June 29, 2013, 05:18:27 PM
I started a new game on the second map.

Got a few more things of note to report, one of which really has me very upset, because I have no idea what happened, other than it kind of wrecked my gaming experience a little bit.

Issue/Out of Place object:
Phase 1, I noticed in the room with the air scrubber, the door switch is in place next to the door. I didn't bother checking the door to see if it would open, but that seems a bit out of place since the adjacent part of the base has not even started construction yet.
<HYPER> not a problem it would be normal to have the equipment in place for expansion.

Issue/Navigating to the Radio Tower:
There were none of those 'navigational markers' (that I saw) near the radio tower. It was a little tricky getting up to it (I went up on the roughly E/NE part of the hill). Are there lights around there, or is the hill generally not really needing the navigational markers?
<HYPER> go up the west side

Issue or possible bug:
Phase 2 start, base pressure warning. Despite being a little over 10psi when I finished Phase 1, it appeared to have dropped down at the start of Phase 2. I guess it was at 5-6 psi, since the air scrubber was showing a little over 6psi when first had a chance to check it.
<HYPER> size of the base doubled yes? so everything gets cut in half. phase 3 gets cut by 1/3 then 1/4

Phase 2, the stairs to the roof, there appears to be a step 'below' the ground, that partly 'clips' through the surface when looking at it from some angels.
<HYPER> had to make sure it would work on various terrains so not a prob.

Issue/Maybe a bug or something else:
When in 3rd person, I had PV panels next to the stairs, but could not pick them up when on the lowest steps. I don't know if the rail counted as a wall, or if in 3rd person the game has the cursor show object names a little outside of the range they can be interacted with. (I was looking down at maybe a 30-45 degree angle when this occurred)

Issue (that has me very upset): The score system, again. I finished Phase 2 at roughly 95%, it dropped to 94 after refilling the rover (no surprise there since the fuel supply dropped a little, I used the rover to speed up moving PV cells to the stairs). After waiting to see if recovering the rover fill will peak up the score a little, alt tabbing out to jot down in my notes about the above issue with being unable to pickup the PV panels. Back in game, I noticed my score starting to go down more. I started checking at very short intervals. I saw my score go down more, then up, then down, then up, and down, and down more, and up a little, then down yet again. it dropped as low as 80 and I managed to snag it at the short jump 82 and simply ended the mission before the game wrecked my Phase 2 score anymore.
Everything was stable. Air was topped out at optimal mix, separator and sebatier were running, etc. Only other thing of note is the sun was setting around the time my score started going bonkers.
<HYPER> score is instant dynamic like you can get a score but by the time the system reports and logs database it may be different by some small ammout like time.

I am seeing stuff like this spammed in the console log about the time my score started to take a nose dive.

Code: [Select]
END GAME DATA RECEIVED 0 2969.03 0 0 0 0 0 0
PHASE TIME runTimeVal1 2969.03
PHASE TIME runTimeVal2 0
PHASE TIME runTimeVal3 0
PHASE TIME runTimeVal4 0
PHASE TIME runTimeVal5 0
PHASE TIME runTimeVal6 0
PHASE TIME runTimeVal7 0

Quick Edit: It starts being 'spammed' shortly after the 'Work orders complete' line in the log for Phase 2.

Here is the log.
http://pastebin.com/2vFGfZSa (http://pastebin.com/2vFGfZSa)
The log is kind of long, from doing Phase 1 and Phase 2, ending at starting Phase 3, then quitting out of the game for now. I feel a little robbed since I managed to get a slightly better score then I did on my first pass through the game.

On a side note, I somehow managed to score 100 for phase 1, without using the airlock override, and despite spending a few minutes in the base doing little due to a storm that interrupted me early on (I already had 6 items in base, so I had something to do part of the time stuck inside). I am guessing that not eating/drinking was one factor, the food bar was a green sliver when I ended Phase 1. Not sure if this is out of place or not, but felt like mentioning it.
With making such good progress in Phase 1, the unusual score behavior in Phase 2 stung a bit more.
<HYPER> will look at it, you should never get a 100%
Post by: rditto48801 on July 01, 2013, 06:57:41 PM
So I guess the construction crews just 'turn off' the air system when they are expanding the base. For some reason, it never occurred to me that it was due to the fact the same amount of air suddenly had more space to fill... I part of me was thinking they were wasting air or something... (cue face palm...)
At least they apparently don't eat up the food, or use up water, oxygen or fuel during the expansion work...   ;D

For the score thing, the main concern is my score dropping from 94 to 80 in just the span of a what seemed to be just few minutes, after completing the work orders for Phase 2.

I did find it interesting with the 100 on Phase 1 with me dropping the ball and being stuck inside several minutes due to a storm. I had pumps and air scrubber parts inside, so I didn't exactly get the initial 'supply chain' going past water...
Would having eaten/drinking nothing, and having diverted a few gallons of water to the water tank, have been a factor for knocking the score out of whack?

Hopefully the log I provided helps shed light on stuff.

When I was on the hill with the radio tower, I didn't have much luck spotting any other way up/down, so I will have to double check the west side the next time I get over that way.

Will the score issues possibly carry on into later stages?
Would it be safe for me to just start over again since I only got the first 2 phases done?
Post by: kyleus on July 01, 2013, 10:09:41 PM
Just got the O2/CO2 - warning and damage.  Was coughing up just a little blood - switching to menthols.

Here's the log: http://pastebin.com/UVaExnEy

Post by: Hyper on July 02, 2013, 08:39:54 AM
I am posting a patch today, I see the bug... hope this fixes the co2 issue and the console spam issue.
Post by: Hyper on July 02, 2013, 12:22:43 PM
I tested the sound and seems the direct x sound is lower level. I use xaudio selection in options and got greater volume....
Post by: rditto48801 on July 03, 2013, 03:34:08 AM
So the issue is with DirectX sound?
*tests it out*
I hadn't noticed there were options other than DirectX Sound.
XAudio does recognize my Sound Blaster Audigy SE, so that's a plus. the Open AL also seems to work, but it is a little 'harder' with the beeping sounds on the sound options menu.

Minor bug.
After a little testing relating to sound settings, the game crashed, and when I restarted it, it had reset my sound settings back to DirectX Sound.
If I can save and exit the game without it crashing, the new audio settings stick with X Audio.

I have not had a chance to update to 1.07 yet. I will probably restart MC:C over after getting the patch, see if I can avoid the 'sudden score plummeting' I ran into on Phase 2 of my second play through.

Edit 3:
Moved my other comment to a better spot.