HyperKat Support and Tester Forum

Mars One => First manned mission to Mars => Topic started by: Hyper on December 24, 2019, 08:57:18 AM

Title: Release 0.38
Post by: Hyper on December 24, 2019, 08:57:18 AM
Make sure you can see hidden files and folders.
Go to c:\Users\YourName\AppData\Roaming\marsone  and delete everything in that folder.
Sorry we have to start over for this to work. You can save your current data directory and I can show you how to recover your place.
Run the game your character should be named Pilot use that one or make a new character.
What SHOULD happen is in the AppData\roaming\marsone folder you will see a directory called Pilot with marsdata in it. Each new character you create will have it's own folder in that directory. You can now have other people playing or you can have multiple characters at different points.

Please let me know you can do this and that it works. 

Computer will now show Farm Hab environment.
Water tanks should work properly now
Equipment like pumps, gpr etc should show on the map correctly
Mission score system is being developed.
Habitation modules lights a bit brighter now.
Added a /time command so you can get local mars time.
BIG UPDATE .. I think I got new players to have their own mission so you can run multiple people/players and each one has a private mission. Still testing but works so far.
Title: Re: Release 0.38
Post by: Hyper on December 29, 2019, 04:15:17 PM
Ok first thing I find. If you get in the mission quit to main menu, make a new character then go back in there is an issue. So log out to desktop, get in game, create new player then get in game. If you have issue doing this just quit to desktop get back in and it should be ok.
Title: Re: Release 0.38
Post by: LostMartian on December 29, 2019, 09:51:28 PM
How odd. I was getting crashes the first few times I tried playing. I couldn't even select a player and get in. Now it seems to be running fine.
There should have been only one player called "Pilot"
Title: Re: Release 0.38
Post by: AC_Black on December 29, 2019, 11:23:03 PM
Hyper, not able to see the new download for 0.38 :(     
Title: Re: Release 0.38
Post by: LostMartian on December 29, 2019, 11:33:25 PM
There seems to be a bug related to playing as one character, exiting the map, then switching to play as another character. It makes the game not work in strange ways.
As I stated in the release notes that is a issue. Log to desktop then get in and make a character.

In my last instance, I tried switching characters twice, and now my character has fallen through the earth (or should I say mars) until it found a bottom. I'm now looking up at the hab module and rocket.
Twice as in log in,out,in,out,in ?
I duplicated this, will fix next version
Title: Re: Release 0.38
Post by: LostMartian on December 30, 2019, 12:10:38 AM
Hyper, not able to see the new download for 0.38 :(   

You may have to refresh the page (F5). I know I had to do it once. It didn't show the latest at the time I looked at it.

Yeah refresh the page when you go there to see the update. This was the easiest way to transport the game. Will be less of an issue when I get it to Beta
Title: Re: Release 0.38
Post by: LostMartian on December 31, 2019, 08:50:48 PM
The current coords for my comm units are as follows:

x -680 y 360

x -270 y 667

These locations seem to satisfy the comm mission in phase 2. This mission seems to need both comm units on the west side of the map. This does not include the comm unit in phase 1.

I found this mission to be more difficult after the bounds of the map were limited to 700 in every direction. The hills go much higher past 700 meters.

I will shorten the comm distance a bit and extend the bounds a bit. Just can't allow the user to see off the edge of the map

radio1 55.8514 -201.617 143.1     radio2 374.877 47.6994 147.   radio3 114.738 289.861 146.7  this works
I think the issue is the text that shows up that you have to be 200m away, I will change that to show valid spots
Title: Re: Release 0.39
Post by: AC_Black on January 02, 2020, 11:47:21 PM
CTD  V0.39

adding fertilizer to plant bed.


This time just finished adding seeds.


This should have been posted in the 0.39 thread.
Will have a look, seems slot 12 is causing a crash. I have run all 3 missions here with no issues.