Author Topic: RELEASE BUGS and ISSUES for 1.05  (Read 12204 times)

0 Members and 1 Guest are viewing this topic.

rditto48801

  • Mission Commander
  • *****
  • Posts: 149
  • Wait, this isn't Duna.
Re: RELEASE BUGS and ISSUES for 1.05
« Reply #15 on: May 29, 2013, 08:40:51 AM »
A minor update.
I checked in MC:C really quick, I got 26 hours just in Phase 6. >.<
Also had a crash when  exiting the mission a second time (went back into mission to double checking the filter level). saved the log (got a few log copies now)

Any suggestions of what I can do with my stuck rover or the floating tool kit stuck in the cargo bed?
Or will the tools reset whenever I actually move on to Phase 7?
I'm guessing the rover itself will reset position as usual.
<HYPER> phase switch might help. I need to pin down how you make that happen so I can fix it.

On a side note, has anyone had trouble logging into the forum?
I'll try to log in via the login stuff on the upper left of the main forum page, then it says I got the wrong password. When I put in the same password at the login failed screen where it says I had the wrong password, it (usually) logs in.
I am trying to figure out what the issue is, or if my keyboard is just having a key or something stick on me, which I have had happen before, but a quick test shows the related keys don't seem to be sticking or anything. If no one else is having such a problem, I will chalk it up to my keyboard not cooperating (it's a cheaper no frills Logitech keyboard).
<HYPER> Are you using IE or firefox?
« Last Edit: May 29, 2013, 08:54:04 AM by Hyper »
Boldly going forward, 'cause I can't find reverse.

Doctor Watson; Proving that being wrong means being one step closer to being right.

Hyper

  • Administrator
  • Mission Commander
  • *****
  • Posts: 1244
Re: RELEASE BUGS and ISSUES for 1.05
« Reply #16 on: May 29, 2013, 08:55:26 AM »
@rditto now that you know some of the quirks of the game why dont you do a full reset and run the game for a score.
And can you supply me with a list of items that have no Info data.
« Last Edit: May 29, 2013, 09:01:09 AM by Hyper »

rditto48801

  • Mission Commander
  • *****
  • Posts: 149
  • Wait, this isn't Duna.
Re: RELEASE BUGS and ISSUES for 1.05
« Reply #17 on: May 29, 2013, 09:48:55 AM »
I will probably at least get to phase 7 and beat it before going on for a full game aimed at getting a good score. If any phase 7 goals involve extra mining, prospecting or food growth, I probably got enough of that done already. I'm a bit of a casual gamer, so scores are usually a secondary concern for me.

Is it possible to have multiple missions going at once? Or would I need to create a second character profile to do that?
<HYPER> at this point you can only have one active mission. V2 will allow what you want.

Hyperia is the 'least hilly' of the maps, correct?
<HYPER> more or less, they all offer a challenge, I like Helios

I guess I can poke around when I get the chance and see what items need descriptions still. I've been a bit distracted with other things. Food and algae will be no problems, I am up to my eyeballs in both.

Speaking of algae, bug or feature that organic fertilizer cannot be used to make algae nutrients?
<HYPER> should work, I will mark it for check for next patch

Maybe also rip everything in the base apart to check parts for descriptions...  :D
I got a spare heater part from the broken down caravan rover mission, so I won't risk the farm/bio lab growth by tearing heaters apart.
(although I am guessing such an approach might be a bad idea in some ways...)

Major bummer on the 128 limitation for surface/core samples kept track of. I would expect a possible limit of 256, but not 128. Oh well. I got in the habit of writing down coordinates  whenever I find samples rated at 20+.
<HYPER> I never have used all the slots. Once I lock in on a resource I move on. You can print maps of the region and use them for notes Next version I can bump it. There are 256 slots for the dots and I use part for one thing and part for another so it's byte indexed.

I use Firefox. It should be up to date. It's set to notify me whenever an update is available.

A comment/opinion of why people are likely not using molten salt thorium reactors, even if the tech was already available.
Money/Greed.
Until it becomes affordable (or someone finds a way to weaponize it), there  will probably be major resistance in adapting stuff to use such a power source. 
Or leave it to Russia to do. I think they have tried out molten salt reactors before (on submarines), and they do tend to use RTGs at remote light houses from what I have read in articles online.

Don't some solar power setups (the type with sunlight focused on a central tower) have some locations that utilize molten salts to store heat so they can make power even at night?

I'm a bit of a fan of pebble bed reactors myself. I read an article on them once (either Popular Science or Popular Mechanics) a few years back. No chance of meltdown sounds like an excellent idea if you ask me. So does the impression that the fuel pellets could be handled using just oven mits and a long pair of grilling tongs...
« Last Edit: May 29, 2013, 01:46:02 PM by Hyper »
Boldly going forward, 'cause I can't find reverse.

Doctor Watson; Proving that being wrong means being one step closer to being right.

rditto48801

  • Mission Commander
  • *****
  • Posts: 149
  • Wait, this isn't Duna.
Re: RELEASE BUGS and ISSUES for 1.05
« Reply #18 on: May 31, 2013, 06:24:40 AM »
I got MC:C going this morning.
This space reserved for a mess of stuff I am looking for (items missing info, typos, etc). 

Still in Phase 6, so if I accidentally wreck the last rover, I can just go to Phase 7 (since they seem to reset to the garage area during a phase change).
Still got to check stuff exterior of the base (stuff immediately outside and rad storage checked, so still need to check main radio towers, portable comms, weather towers, and the augers)

I forgot there was no info for 'carried' objects... so I have no idea why I mentioned the idea to rip everything apart to check for item info...  :-[
Lucky I had a backup two backup things salvaged from the broke down caravan rover mission to check before I did go tearing stuff apart. Except the air scrubber, I took out and reinstalled the filter to see if it 'un-sticks' the filter level.
Boldly going forward, 'cause I can't find reverse.

Doctor Watson; Proving that being wrong means being one step closer to being right.

rditto48801

  • Mission Commander
  • *****
  • Posts: 149
  • Wait, this isn't Duna.
Re: RELEASE BUGS and ISSUES for 1.05
« Reply #19 on: May 31, 2013, 11:31:15 AM »
Okay, felt the need to just toss this in a new post so I could more easily format stuff...

Anyways, today, I present to you what happens when I get into what I call a 'kill it with fire!' bug hunting mood... (partly on account I did not sleep well last night...)

Here is my latest bug, typo, and 'missing description' list.
(sorry for duplicates of things I may have mentioned already)
Also, a few other things of note.

Bugs/Possible Bugs

Bug/Feature?: Algae D + Algae D provides plastic like Algae D + Beans/Potato
ChemDesk/Chemistry Station info for it says "Algae D Potatoes or Beans" for needed items, so the wording does not help.

Bug/Wording Mistake?: Bio-Processor says it processes mushrooms and worms, but rejects them.

Bug/Just plain lucky?: I have never needed to use the medicine Dulacine. Or only required due to food poisoning from raw food?

Bug/Feature?: When the mix abruptly 'goes bad' (a bug itself?) damage is instant (9 damage?). Shouldn't there be a brief 'warning' or 'slack' with that feature? Even with a sudden lack of oxygen, there should be a roughly 15 second window anything serious happens (like passing out from no oxygen). Maybe a few quick 'warnings' in the message window (and in the main view) before damage is incurred over a period of time, rather than in chunks of 9 damage?
 
Bug/Feature?: When repairing something, if the Adjust/Redo check pops up early on (about 1/5-1/4 of the progress bar), selecting the right option causes repair progress to jump to about 2/3-3/4 done. Edit: Forgot to mention that it effectively seems to be a roughly 50% jump in repair progress.

Bug/Feature?: Cannot interact with PVRemote next to the RadStore/Containment

Bug/Feature?: When setting an Auger to 0 depth to retract the drill, it does not turn off when it gets to depth 0.

Bug/Feature?: Sabatier shuts off before Methane is full (O2 will filll to 400, Methane will only fill to slightly over 99.x)

Bug?: The two lights in the garage seem to have a basic 'glowing aura' around them (as if on) when turned off (during day).

Bug? Sometimes when turning on a Water Pump, it immediately goes back to Idle. Exiting the GUI and selecting it again shows it is Running

Bug/Feature?: Right click menu for (Algae) Nutrients shows 'food' (as the item type, I'm guessing)

Bug?: Right click menu, if right clicking to bring up the drop down menu, and then dragging the item into a container, the right click menu bar remains where the item used to be.

Bug/Feature?: Dragging Algae Nutrients into the Algae Tank, or Fish Food into the Fish Tank, has the has it immediately added to the nutrient/food value, without needing to use the 'add' button.

Bug/Feature?: Algae based Edible Meal only fills about 20-25% of the Food bar.

Bug: Portable Light not 'working' normally.
I was was trouble shooting the issue more.
2 connected factors I can find.
#1: If the portable light had been in the rover before being removed from cargo, placed and turned on less than 10m from the rover.
#2: if the rover was moving with its lights on prior to the portable light being removed, placed and turned on.
It appeared that just placing the light, moving the rover near it with lights on (and turning them off after stopping), then turning on the portable light, had it turn on, but the light did not seem as bright as normal. This was before I put the portable light on the rover. The testing was done just outside of the geology hub, it was after 0:00 hours, so still very dark outside).
I had moved a short ways away with the light in the rover before deploying it (rover lights were on during the short drive, turned back off after stopping) and had the portable light produce no visible light. During the testing, short drive without the rover lights on, carrying the light in the rover cargo during the drive before placing it, did seem to cause a lesser effect of the portable light not creating as bright of a light as normal. (things got a little out of order in my notes, I think this occurred before the 'no light at all' thing fully occurred...)
After the test, took the portable light back into the geology hub where I had it stored previously, and tried it again a last time and it then produced light again like it should. This is similar to a previous occurrence, the portable light had stopped producing light, but had worked normally a little after when I had moved it to another location via rover and deployed it about 20-30m away from the rover, rather than within 5m or so like I normally do (I park really close to present/planned work sites).
Edit (extra info): I got to wondering if perhaps the game is getting slightly confused with interactions between 'stationary' and 'mobile' light sources. Like  if the portable light shows less or no light because the game still 'thinks' another light source (the rover) is illuminating the area.


Also, how do I recharge a portable light? I tried the drill bench (since the core sample drill can be recharged there) but nothing happened. Also tried EVA Recharge with it in hand with no effect...


Typos, Wording, etc.

Typo?: CommDesk/Communications. Info has some all caps, LAND COMMUNICATIONS, LOCAL, and REMOTE. All capital letters intended?

Typo: Auger. Info, 5th line. 'Use the oer boxes to empty the collection box on the auger'

Typo?: Heater Info. Last line ends with three periods.

Typo?: RadStore/Containment. 'Consainment' instead of 'Containment' in first line. (nice coincidence that the rad bar went yellow on the walk there...)

Wording Confusion: Description for making plastics. Mainly  'pre processed'. Maybe better to just be 'processed'? Some might see 'pre' to mean 'before' processing the plant.

Wording issue, Suggestion: Info for BioDesk/Biology Station says Algae A makes 'compressed food blocks', but instead makes a ready ediblle meal. Maybe the game needs an 'Algae Food Block' item... (can any more items be added to the Freezer GUI?)

Wording issue, Suggestion: Freezer/Food Storage: End of first line, '... MRE cooked packaged food'.
Possible better description for that bit, 'MRE (Meal Ready to Eat), a pre-cooked, packaged food'.

Wording issue, weather towers. I don't quite get the 'place 90 degrees of each other' stuff. Makes me want to put them in a 'square' pattern...

Wording Issue, Worm/Mushroom Beds. Info says 'DO Not over water'. Wouldn't it look better as 'Do Not' or 'DO NOT'?

Wording issue: Power Distribution Unit: Tweak description to include mention of what battery bank powers the external lights?

Wording Issue, Suggestion: Medical Station/MEDICAL DIAGNOSIS STATION: All capital letters intended? Add a bit more info on what it does/how it works/why it is needed?

Wording issue/Punctuation?: LIBS: First line . Missing punctuation after Spectrometer in first line? ("Laser Induced Breakdown Spectrometer Use this device to test rock and dirt samples.")

Wording issue/Punctuation?: RadStore/Containment: Info perhaps needs punctuation (missing a comma or two in the 'second' line?).

Info Suggestion: Bio Waste, add mention of 'gray water' and 'bio solids' for extra detail in the Info? (or is that to much info for the subject?)

Info Suggestion: PLSUnit/EVA Charge: Info does not state where you charge/refill it at.
(I am assuming the Rover refueling point. Never really used the PLS Unit myself. Radiation bar going yellow has me running back to base often enough to not run low on O2/Energy)

Info Suggestion: FuelStation/Fuel: If the PLS is chargeable here, mention it in the Fuel Station info??

Conflicting Info: GprSupply/GPR Supply, the GUI shows ranges for GPR charges, but I had one shot reveal nothing, a message on screen indicated nothing was within 350m. That and ranges I have detected deposits at suggests the GPR shots cover a wider range than what GPR Supply listed ranges are. I missed one deposit that was 72m deep with a wide shot, so the Depth range is apparently as the GPR Supply GUI states for the Wide shots.


Objects and stuff.

Suggestion/Item Management: Ability to do something with Edible Food and (drinking) Water. During testing, I ended up with slots taken up by those while checking stuff... (food was Algae based, so short wait until I could safely eat it... accidentally double clicked drinking water...). Slowed down checking work a little, but nothing crippling.

Suggestion/Object Interaction: Add a name and GUI with Info to the red tool case in the garage? Like mentioning that rovers near it can be repaired better (full repair instead of temp repair) when a Rover is parked near it?

Suggestion/Object Interaction: An option to allow transferring water from the Separator, to the Water Supply, without needing to turn on the Separator

Suggestion/Object Interactions: A 'box' for the WormShroomInv/Bio Storage, so removed worm/mushroom starters/nutrients can be put back if they are accidentally taken out.

Suggestion/Object Interactions: A 'confirmation prompt' of some sort when going to drain an Algae Tank.

Suggestion/Sounds: Add a few sounds for when doing stuff like food prep, or working at the different 'crafting' stations? (making plastics, turning algae into food, etc). Nothing major, just little basic sound effects (bubbling, sizzling/hissing, light hitting/tapping or mixing/stirring type sounds?)

Images/Icon issues/suggestions, etc.

Image Issue/Suggestion: The icons for the fish are a bit to 'colorful'. Would it be possible to find get something a little more 'natural' looking?

Image Issue: I noticed the dark spots in the middle of the Fish Fillet icon is actually 'transparent'.

Image Issue/Suggestion: A bit of color variation (and perhaps secondary markings) might be nice for fertilizers, plastics, and just about anything else that uses the same basic inventory icon.

Model/Texture Issue: Food prep table. I noticed the 'inside' of the bowls and cups have textures, but not the 'outside'. That is, they are 'invisible' on the outside for me. (I have a HIS made Radeon HD 4670 IceQ w/ 512MB RAM)

Model/Collision Issue: Player can clip through the Rover wheels.

Image Suggestion: Minor variations for the icons for the different medicines?

Misc stuff.

Thing of Interest: Outside temp being -7.5.x during the day. Is that unusual?

Thing of Interest: I got a brief speed warning when I started going up a hill (shallow grade at first)

Thing of Interest: Thinking back, I don't think I have seen a single storm since I got to Phase 6. I have seen multiple times where the pressure reading went red and dipped below 0.30 for a short period of time.

Object Access Issue: It is hard to interact with (get the GUI to pop up) the Satellite unit on the base. I have to stand on the side of the path leading to it and be as close as possible to get the GUI to pop up.





Missing Item Description List:
("Information about objects under construction")

Potato, Beans, Zucchini (Plants, Seeds and Raw Food forms)
Mushroom
Bass, Trout, Catfish
Fish Fillet
Frogs
Frog Legs
Fish Eggs (all 4)
Meat Mush/Meat
Algae (A, B, I think also D, but had none right now, used a lot before switching to B. Probably also C)
Algae 'starters'
Processed Minerals (The ones that started in fab storage, and apparently all minerals/elements I have gotten in Phase 6, at least the ones that I checked).
Plastics
Fertilizer, Organic (Fertilizer)
Algae Nutrients

I did not check items in WormShroomInv/Bio Storage, on account I don't think they can be put back when taken out. (hence a suggestion higher up the list to add such an option). I kept some in reserve, just in case, and don't want to waste any. That and could I even use worm/mushroom starters if their respective growing units already have growth in them? I wouldn't want items stuck in my inventory with no way to get rid of them.


Items/Objects with no Info option/button

MRE
Medicines (all four items, Propodine, Dulacine, Radicium, MedPack)
FarmWaterTank/Water Supply
Microwave
Seed Storage (GUI lacks object name)
PlantExtract: Also, GUI interface shows name as PLANT Processor
FishFoodInv
FishEggInv
WTowerStore
Plastic
Water (drink)
Raw Meal
Edible Meal
OxygenTank/Oxygen
FabStore/Object Storage
Geology Desk ('feature' since it pops up the same map as the EVA suit has?)
MechDesk (I guess no surprise, no GUI unless there is an item to test/repair)
PortaLight/Portable Light
OreStore/Ore Stock
OreProcess/Ore Processing
DrillTools/Drill Repair Kit
GprDevice/GPR Unit
GprSupply/GPR Supply
PVMount/PVPanel#




Other stuff...


Where's the... power?
An observation.
Those red light beacon poles marking the safe paths to the comm towers... a pole... with a light... what powers them? Same for the weather stations and portable comms. And the Augers...
The portable lights and core sample drill need to be recharged, why not other items?
At the very least, it would make sense if the models for the portable comm towers, portable weather stations and those little beacon lights to have something like small solar panels or something on them.


EVA testing of power drain and suit temp settings:
Exterior temperatures seem to not affect suit power usage when in the base. Maybe just to little of a difference to drain much power?
Test 1: Suit on in base (temp 18.2), suit temp 4.8
O2: 82.4
Energy: 85.1

Test 2: suit temp 20.2, base temp 20.1 (farm at 20.2, reset heater 1 to the same, forgot in first test)
O2: 80.6
Energy: 83.6

Test 3: Suit temp 4.8, base temp (both heaters) 20.1 (ext temp reading 20.1)
O2: 82.9
Energy: 85.5

It seems regardless of temp, energy usage was mostly the same, except for with high suit temp set close to ext temp, which seems to be. I was mostly moving around during these tests, so O2 usage should have a semi-consistent drain in each test.
In test 1 and 3, O2 usage is roughly 3.2% higher than energy, test 2 is 3.7% higher.
Not sure if this info is useful or not, but I felt it stuck out enough to mention.

Outside energy generally drains faster than O2.

Maybe it's just a non issue and I am straying from 'bug hunt' territory into 'witch hunt' territory...

Edited: Added something (or rather a few things) I forgot, fixed a few (non-game) typos.
« Last Edit: June 01, 2013, 05:32:58 AM by rditto48801 »
Boldly going forward, 'cause I can't find reverse.

Doctor Watson; Proving that being wrong means being one step closer to being right.

Hyper

  • Administrator
  • Mission Commander
  • *****
  • Posts: 1244
Re: RELEASE BUGS and ISSUES for 1.05
« Reply #20 on: June 01, 2013, 09:53:47 AM »
All valid points and will be addressed in time.
Early patches are for major issues like being in the rover holding and item is worthy of a immediate fix.
I have coppied all this over to dev notes for revision as I get to them.
Thanks for all the hard work .... where were you when we were testing..... <grin>

rditto48801

  • Mission Commander
  • *****
  • Posts: 149
  • Wait, this isn't Duna.
Re: RELEASE BUGS and ISSUES for 1.05
« Reply #21 on: June 01, 2013, 12:23:30 PM »
You're welcome.
I guess my efforts are partly due to being more of a casual gamer at times, and wandering off to do 'whatever' rather than focusing on objectives. Or bouncing between different games in general, so I have a semi-fresh perspective when I get back to a game.
That, and maybe a little bad luck at times... And sometimes when a bug annoys me, I just feel the need to troubleshoot it into a smoking crater. Except for big name titles, usually kind of pointless there... In one case, a developer wanted to continue patching a game, but stopped patching said game because the publisher forbid it from being patched more...

As for where I was when you were testing... probably grinding myself silly on some sort of coop game with a friend... or playing Kerbal Space Program with a healthy dose of game imploding mod soup... but I did help track down one annoying bug there... someone 'broke' the Vehicle Assembly Building because a few certain parts did not like clipping into other parts in certain ways when surface attached at an angle. I've done a little helping on the support area off the KSP forums to mainly with a few issues I had run into myself a lot myself, relating to previously mentioned game imploding mod soup...

I will admit I had an interest in MC:C when it first popped up on Steam Greenlight, but I was a little put off at first by the fact the forums were mostly 'private', preventing me from taking a peek to see what things were like. I usually like to 'lurk' a while before I sign up to a forum.
<HYPER> That forum thing was a result of people posting porn and torrent links. I had to restrict things to real users.

Edit:

I was playing with 1.06 a little bit.

I was able to grab the 'floating in air' tool kit, so that issue is resolved, and I got my second rover back to the garage and fixed up.

Two things I forgot to put in my above list, both minor.
First, the in game volume being very low.
Second, the crates the weather stations were stored in are sort of 'floating in air', they are not 'sitting' on the ground/the lower crate.
<HYPER> There was a shelf graphic that is supposed to be there. The artist that did it is gone now. I'll see if I can add it back in.

One thing I just stumbled upon while toying around with the fabrication desk.
I built an Electronics Kit, just to see how things worked with the fabrication process. After it popped up in inventory when done, I right clicked, and saw a 'blank' entry in the drop down window. When I clicked on the blank spot to see if it would bring up info or similar, the kit instead disappeared from my inventory. ('invisible' drop option?)
I was expecting it to be a 'carried' item. Can the repair kits be stored in the fabrication storage by any chance, since they are inventory items and not carried items?

<HYPER> those items should be able to store in the storage lockers, will have a look...
« Last Edit: June 01, 2013, 05:09:22 PM by Hyper »
Boldly going forward, 'cause I can't find reverse.

Doctor Watson; Proving that being wrong means being one step closer to being right.

Hyper

  • Administrator
  • Mission Commander
  • *****
  • Posts: 1244
Re: RELEASE BUGS and ISSUES for 1.05
« Reply #22 on: June 01, 2013, 05:10:26 PM »
Will create a new topic for 1.06

rditto48801

  • Mission Commander
  • *****
  • Posts: 149
  • Wait, this isn't Duna.
Re: RELEASE BUGS and ISSUES for 1.05
« Reply #23 on: June 01, 2013, 05:24:20 PM »
Alright.

I built a Pump Assembly for a quick second check of fabrication, and it's right click menu also had the first option being 'empty' (I clicked on cancel with this time), then I tossed it in storage with no issue.

On a side note, I am still in Phase 6...
After I relocate my augers, I will (maybe) get on to Phase 7 to see if I run into anything out of the ordinary with it. I am having fun just wandering around doing stuff.
The tale of the Tortoise and the Hare comes to mind...

Edit: *face palm* for putting Turtle instead of Tortoise...

Edit 2:
Quick question, are resources found (via Plibs, ,then GRP, then, core drill sample and then confirmed with Libs) count toward score?
<HYPER> I made no distinction on how the material was found other than what is in the work orders as a minimum.
Are you running the 1.06 patch ?

« Last Edit: June 01, 2013, 06:41:54 PM by Hyper »
Boldly going forward, 'cause I can't find reverse.

Doctor Watson; Proving that being wrong means being one step closer to being right.

rditto48801

  • Mission Commander
  • *****
  • Posts: 149
  • Wait, this isn't Duna.
Re: RELEASE BUGS and ISSUES for 1.05
« Reply #24 on: June 01, 2013, 09:57:46 PM »
As I stated in my post from earlier today, I do have 1.06. I mentioned it in the post mentioning the apparently floating weather tower storage crates. (Edit: I sort of missed the new 1.06 thread. I guess new/continuing issues I stumble across should be listed there)

I was curious about how exactly discovered resources might count toward score. I think I have got about 12 of the 20 resources found.

I was also curious because it seems like my score in Phase 6 never got to 60, and I partly assume it is due to how long I have played in Phase 6. I do have all work orders done for Phase 6.

I guess my wording was probably poorly chosen for putting different steps of finding/identifying resources 'in order'.
I guess it would have been better just to ask if/what any of the finding/identifying steps counts toward score.

So finding resources past what is needed for work orders won't affect score or won't affect it as much?
Edit: What about stored resources from mining. My score seems to jump around a bit and I am trying to figure out what all the factors are (I've basically guess that stored fuel is one thing, since my score seems to drop a point or so when I refuel the rover after a long trip, and seems to 'recover' about the time it is topped off again)
« Last Edit: June 02, 2013, 08:39:26 AM by rditto48801 »
Boldly going forward, 'cause I can't find reverse.

Doctor Watson; Proving that being wrong means being one step closer to being right.